Java Support Matrix

This matrix shows the Java Development Kit versions supported by different HPE Ezmeral Data Fabric releases.

Only the Oracle, OpenJDK, and Amazon Corretto Java engines are supported.

Java/Data Fabric Release Release 7.6.x Release 7.5.0 Release 7.4.0 Release 7.3.0 Release 7.2.0 Release 7.1.0 Release 7.0.0 Release 6.2.0 Release 6.1.x Release 6.0.x Release 5.2.x
Java 171 Yes Yes Yes Yes Yes No No No No No No
Java 11 Yes Yes Yes Yes Yes Yes Yes Yes No No No
Java 82 No No No No No No No No Yes Yes Yes

1Using the monitoring components with JRE or JDK 17 is supported only in EEP 9.2.0 or later.

2Only the Oracle and OpenJDK Java engines are supported.