CSI Version Compatibility

Shows the released versions of the Container Storage Interface (CSI) storage plugin and their compatibility with other components in a Kubernetes environment.

CSI Storage Plugin Version Compatibility
FUSE or Loopback NFS Kubernetes2 CSI Spec Core OS for Kubernetes Nodes OpenShift HPE Ezmeral Runtime Enterprise
1.0.x1 Loopback NFS 1.17 and later3 1.3.0 Release 6.1.0 and later5
  • RHEL
  • CentOS
  • Ubuntu
  • 4.15
  • 4.14
  • 4.13
  • 4.10
  • 4.94
  • 4.83
  • 4.73
  • 4.6
  • 4.5
  • 4.4
  • 5.6.x
  • 5.5.x
  • 5.4
  • 5.3.x
1.2.x1 FUSE 1.17 and later3 1.3.0 Release 6.1.0 and later5
  • RHEL
  • CentOS
  • Ubuntu
  • 4.15
  • 4.14
  • 4.13
  • 4.10
  • 4.94
  • 4.83
  • 4.73
  • 4.6
  • 4.5
  • 4.4
  • 5.6.x
  • 5.5.x
  • 5.4
  • 5.3.x
1.1.0 FUSE 1.16 and later 1.3.0 Release 6.1.0 and later5
  • RHEL
  • CentOS
  • Ubuntu
  • 4.3
  • 4.2
  • 5.1
  • 5.0
1.0.2 FUSE 1.13 and later 1.0.0 Release 6.1.0 and later5
  • RHEL
  • CentOS
  • Ubuntu
  • 4.2
  • 4.1
  • 5.1
  • 5.0
1.0.0 FUSE 1.13 and later 1.0.0 Release 6.1.0 and later5
  • RHEL
  • CentOS
  • Ubuntu
  • 4.2
  • 4.1
  • 5.1
  • 5.0

1Supports Raw Block Volumes.

2Includes support for the specified Kubernetes versions as part of a Google Anthos Kubernetes distribution.

3If your environment uses Kubernetes 1.20+ and OpenShift 4.7+, you must use FUSE 1.2.1+ and Loopback NFS 1.0.1+.

4If your environment uses Kubernetes 1.22+ and OpenShift 4.9+, you must use FUSE 1.2.6+ and Loopback NFS 1.0.6+.

5In a release 7.0.0 environment, you must use Fuse 1.2.8+ and Loopback NFS 1.0.8+.