Operating System Support Matrix

The tables on this page show the Linux operating-system versions that are supported for HPE Ezmeral Data Fabric releases.

For a list of the EEPs that you can use with each core release, see EEP Support and Lifecycle Status.

Red Hat Enterprise Linux (64-bit)

NOTE
The RHEL versions in the following table have been certified with the specified HPE Ezmeral Data Fabric versions.

HPE recommends pinning your deployment to a certified version. If your RHEL instances are not pinned to a specific version, and there is a later RHEL minor release available, then updates for packages (including security updates) come from the later release. If this later release is not certified, the new package versions might cause issues with your deployment.

RHEL Version Release 7.7.x Release 7.6.x Release 7.5.0 Release 7.4.0 Release 7.3.0 Release 7.2.0 Release 7.1.0 Release 7.0.0 Release 6.2.0 Release 6.1.1 Release 6.1.0 Release 6.0.1 Release 6.0.0
9.0 Yes8 No No No No No No No No No No No No
8.8 Yes Yes Yes Yes No Yes5 No No No Yes5 Yes5 No No
8.6 Yes Yes Yes Yes Yes Yes Yes Yes Yes No No No No
8.5 Yes Yes Yes Yes Yes Yes Yes Yes No No No No No
8.4 Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes1, 2, 3, 4 Yes1, 2, 3, 4, 5 No No
8.3 Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes1, 2, 3, 4 Yes1, 2, 3, 4, 5, No No
8.2 Yes Yes Yes Yes Yes Yes Yes Yes Yes No Yes1, 2, 3, 4, 5 No No
8.1 Yes Yes Yes Yes Yes Yes Yes Yes Yes No No No No
7.9 No No No No No No No No No Yes Yes5 Yes6 No
7.8 No No No No No No No No No No Yes5 Yes6 No
7.7 No No No No No No No No No No Yes5 No No
7.6 No No No No No No No No No No Yes No No
7.5 No No No No No No No No No No Yes Yes7 No
7.4 No No No No No No No No No No Yes Yes Yes
7.3 No No No No No No No No No No Yes Yes Yes
6.10 No No No No No No No No No No No No No

1Supported only for EEPs 6.3.0 and later.

2NFSv4 is not supported for core 6.1.0 on Red Hat Enterprise Linux / CentOS 8.x.

3Hue 4.3.0 in EEP 6.3.0 and 6.3.1 is not supported for Red Hat Enterprise Linux (RHEL) or CentOS 8.x. However, Hue 4.3.0.300 in EEP 6.3.2 can be used with RHEL or CentOS 8.x.

4Installing release 6.1.0 on RHEL or CentOS 8.x requires you to enable the EPEL repository. Starting in RHEL 8.x, a mapr-core-internal package dependency (sdparm) is deprecated and moved to EPEL, and installation cannot complete without enabling it. For information about adding repositories, see Adding the Data Fabric Repository on RHEL, CentOS, or Oracle Linux.

5May require a patch. For best results, apply the latest EBF. To install patches, see Applying a Patch.

6Requires a patch. Certified only for EEP 5.0.4. Other EEPs supported by release 6.0.x might work but have not been certified.

7Use Installer 1.10 or later with this release. Before upgrading your operating system to Red Hat Enterprise Linux 7.5, CentOS 7.5, or SLES12 SP3 or later, be sure to update the Installer to version 1.10 or later. See Updating the Installer.

8Supported only for new installations. Upgrades to Release 7.7.0 on this OS version are not currently supported.

CentOS (64-bit)

CentOS Version Release 7.7.x Release 7.6.x Release 7.5.0 Release 7.4.0 Release 7.3.0 Release 7.2.0 Release 7.1.0 Release 7.0.0 Release 6.2.0 Release 6.1.1 Release 6.1.0 Release 6.0.1 Release 6.0.0
8.31 No No No No No No No No Yes No Yes2, 3, 4, 5, 6 No No
8.21 No No No No No No No No Yes No Yes2, 3, 4, 5, 6 No No
8.11 No No No No No No No No Yes No No No No
7.9 No No No No No No No No No Yes Yes No No
7.8 No No No No No No No No No No Yes2 Yes7 No
7.7 No No No No No No No No No No Yes2 No No
7.6 No No No No No No No No No No Yes No No
7.5 No No No No No No No No No No Yes Yes8 No
7.4 No No No No No No No No No No Yes Yes Yes
7.3 No No No No No No No No No No Yes Yes Yes
6.10 No No No No No No No No No No No No No

1CentOS Linux 8 has reached End of Life (EOL) status. For OS upgrade and migration information, see the CentOS Linux EOL advisory. See also the HPE Ezmeral Data Fabric Advisory in response to CentOS 8 Discontinuance.

2Requires a patch. See the associated support advisory. To install patches, see Applying a Patch.

3Supported only for EEPs 6.3.0 and later.

4NFSv4 is not supported for core 6.1.0 on Red Hat Enterprise Linux / CentOS 8.x.

5Hue 4.3.0 in EEP 6.3.0 and 6.3.1 is not supported for Red Hat Enterprise Linux (RHEL) or CentOS 8.x. However, Hue 4.3.0.300 in EEP 6.3.2 can be used with RHEL or CentOS 8.x.

6Installing release 6.1.0 on RHEL or CentOS 8.x requires you to enable the EPEL repository. Starting in RHEL 8.x, a mapr-core-internal package dependency (sdparm) is deprecated and moved to EPEL, and installation cannot complete without enabling it. For information about adding repositories, see Adding the Data Fabric Repository on RHEL, CentOS, or Oracle Linux.

7Requires a patch. Certified only for EEP 5.0.4. Other EEPs supported by release 6.0.x might work but have not been certified.

8Use Installer 1.10 or later with this release. Before upgrading your operating system to Red Hat Enterprise Linux 7.5, CentOS 7.5, or SLES12 SP3 or later, be sure to update the Installer to version 1.10 or later. See Updating the Installer.

Rocky Linux (64-bit)

Rocky Version Release 7.7.x Release 7.6.x Release 7.5.0 Release 7.4.0 Release 7.3.0 Release 7.2.0 Release 7.1.0 Release 7.0.0 Release 6.2.0 Release 6.1.1 Release 6.1.0 Release 6.0.1 Release 6.0.0
8.5 Yes Yes Yes Yes Yes Yes Yes Yes Yes1 No No No No
8.4 Yes Yes Yes Yes Yes Yes Yes Yes Yes1 No No No No

1Release 6.2.0 support on Rocky Linux 8.4 and 8.5 requires mapr-patch-6.2.0.20.20220402213719.GA-1.x86_64 or later. EEP components are not currently supported for use with release 6.2.0 on Rocky Linux 8.4 and 8.5.

Ubuntu (64-bit)

Ubuntu Version Release 7.7.x Release 7.6.x Release 7.5.0 Release 7.4.0 Release 7.3.0 Release 7.2.0 Release 7.1.0 Release 7.0.0 Release 6.2.0 Release 6.1.1 Release 6.1.0 Release 6.0.1 Release 6.0.0
22.04 Yes1, 3 No No No No No No No No No No No No
20.04 Yes Yes Yes Yes Yes Yes Yes Yes No No No No No
18.04 Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes No No
16.042 No No No No No No No No Yes Yes Yes Yes Yes
14.04 No No No No No No No No No No Yes Yes Yes

1Supported only for new installations. Upgrades to Release 7.7.0 on this OS version are not currently supported.

2RDMA is not supported with release 6.2 on Ubuntu 16.04.

3Release 7.7.0 has a dependency on the libssl1.1 package, which is not included in Ubuntu 22.04. To resolve this issue, see the Ubuntu 22.04 dependency information in Installation Notes (Release 7.7).

SLES (64-bit)

SLES Version Release 7.7.x Release 7.6.x Release 7.5.0 Release 7.4.0 Release 7.3.0 Release 7.2.0 Release 7.1.0 Release 7.0.0 Release 6.2.0 Release 6.1.1 Release 6.1.0 Release 6.0.1 Release 6.0.0
15 SP3 Yes Yes Yes Yes Yes Yes Yes Yes1 Yes1, 5 No No No No
15 SP2 Yes Yes Yes Yes Yes Yes Yes Yes1 Yes1, 2 No No No No
12 SP5 No No No No No No No No No Yes Yes3 No No
12 SP4 No No No No No No No No No Yes Yes3 No No
12 SP3 No No No No No No No No No No Yes Yes4 No
12 SP2 No No No No No No No No No No Yes Yes Yes

1NFS v4 is not supported for the specified 7.x releases and 6.2.0 when installed on SLES 15.

2Requires a patch (core 6.2.0.7 or later). The repository automatically provides the right patch version.

3Requires a patch. See the associated support advisory. To install patches, see Applying a Patch.

4Use Installer 1.10 or later with this release. Before upgrading your operating system to Red Hat Enterprise Linux 7.5, CentOS 7.5, or SLES12 SP3 or later, be sure to update the Installer to version 1.10 or later. See Updating the Installer.

5Requires mapr-patch-6.2.0.25.20220708033007.GA-1.x86_64 or later and EEP 8.1.0. See also known issue MFS-15087 in Known Issues (Release 7.7).

Oracle Enterprise Linux

OEL Version Release 7.7.x Release 7.6.x Release 7.5.0 Release 7.4.0 Release 7.3.0 Release 7.2.0 Release 7.1.0 Release 7.0.0 Release 6.2.0 Release 6.1.1 Release 6.1.0 Release 6.0.1 Release 6.0.0
8.4 Yes1 Yes1 Yes1 Yes1 Yes1 Yes1 Yes2 Yes3 No No No No No
8.3 Yes3 Yes3 Yes3 Yes3 Yes3 Yes3 Yes3 Yes3 No No No No No
8.2 Yes3 Yes3 Yes3 Yes3 Yes3 Yes3 Yes3 Yes3 Yes3 No No No No
7.8 No No No No No No No No No No Yes2, 4 No No
7.4 No No No No No No No No No No Yes2 Yes2 Yes2
7.3 No No No No No No No No No No Yes2 Yes2 Yes2

1Both core and ecosystem components (EEP 9.1.0 and later 9.x.x) can be used on the supported versions of Oracle Enterprise Linux.

2Only Data Fabric core software can be used on the supported versions of Oracle Enterprise Linux. Ecosystem components are not supported.

3Both core and ecosystem components (EEP 7.x.x and later) can be used on the supported versions of Oracle Enterprise Linux.

4Requires a patch. To install patches, see Applying a Patch.