Support Matrixes

This section provides information about support and interoperability for HPE Ezmeral Runtime Enterprise and its components.

This section provides information about support and interoperability for HPE Ezmeral Runtime Enterprise and its components.

This information supplements information about system requirements. See System Requirements

OS Versions

See OS Support.

GPU Support

For hardware support, see the following table. For software, driver, and MIG support, see GPU and MIG Support.

HPE Ezmeral Runtime Enterprise Release Version GPU Hardware
5.4.0-5.6.4 NVIDIA Tesla K80 (AWS environment1)

NVIDIA Tesla P4

NVIDIA Tesla T4

NVIDIA Tesla P100

NVIDIA Tesla V1001

NVIDIA Quadro P40001

NVIDIA A30 with MIG mode

NVIDIA A100 with MIG mode1

5.3.5-5.3.6 NVIDIA Tesla P4

NVIDIA Tesla P100

NVIDIA Tesla V100

NVIDIA A100 with MIG mode

5.3.1 NVIDIA Tesla P4

NVIDIA Tesla P100

NVIDIA Tesla V100

NVIDIA Tesla A100 (non-MIG mode only)

1 Fully tested

HPE Ezmeral Runtime Enterprise Components

Table 1. Components by HPE Ezmeral Runtime Enterprise Release
HPE Ezmeral Runtime Enterprise Release Version HPECP Agent HPE Kubectl Plugin Kubectl Client Container Runtime (All OS)
5.6.4 1.3.1-7e1d6f6-04f50a2 3.7-18 1.23.10-hpe1 containerd 1.6.9.hpe-1,

Docker CE 19.03 (On Controller, Shadow Controller, Arbiter, and Gateway hosts, and legacy Kubernetes hosts from upgraded deployments only.)

5.6.2 1.3.1-7e1d6f6-04f50a2 3.7-18 1.23.10-hpe1 containerd 1.6.9.hpe-1,

Docker CE 19.03 (On Controller, Shadow Controller, Arbiter, and Gateway hosts, and legacy Kubernetes hosts from upgraded deployments only.)

5.6.1 1.3.1-7e1d6f6-04f50a2 3.7-18 1.23.10-hpe1 containerd 1.6.9.hpe-1,

Docker CE 19.03 (On Controller, Shadow Controller, Arbiter, and Gateway hosts, and legacy Kubernetes hosts from upgraded deployments only.)

5.6.0 1.3.0-02f5d92-2e67bb4 3.6 1.20.2 containerd 1.6.9.hpe-1,

Docker CE 19.03 (On Controller, Shadow Controller, Arbiter, and Gateway hosts, and legacy Kubernetes hosts from upgraded deployments only.)

5.5.1 1.2.7-234eba4-6155d23 3.6 1.20.2 containerd 1.5.1.hpe-1,

Docker CE 19.03 (On Controller, Shadow Controller, Arbiter, and Gateway hosts, and legacy Kubernetes hosts from upgraded deployments only.)

5.5.0 1.2.5-5df266a-6155d23 3.6 1.20.2 containerd 1.5.1.hpe-1,

Docker CE 19.03 (On Controller, Shadow Controller, Arbiter, and Gateway hosts, and legacy Kubernetes hosts from upgraded deployments only.)

5.4.1 1.2.2 3.5.13 1.20.0 Docker CE 19.03
5.4.0 1.2.1 3.5.13 1.20.0 Docker CE 19.03
5.3.5-5.3.6 1.1.13 3.4-14 1.20.0 Docker CE 19.03
5.3.1 1.1.5 3.4-14 1.20.0 Docker CE 19.03

HPE Ezmeral Data Fabric

HPE Ezmeral Runtime Enterprise supports the use of different implementations of HPE Ezmeral Data Fabric. Depending on the release version, a given implementation of HPE Ezmeral Data Fabric can be connected as external storage, registered as Tenant/Persistent storage, or both.

In summary, the implementations of HPE Ezmeral Data Fabric are the following:

HPE Ezmeral Data Fabric on Bare Metal

HPE Ezmeral Data Fabric on Bare Metal is an implementation of HPE Ezmeral Data Fabric that is on physical or virtual machines that are not part of the HPE Ezmeral Runtime Enterprise deployment.

HPE Ezmeral Data Fabric on Bare Metal is the only supported implementation of HPE Ezmeral Data Fabric for production deployments of HPE Ezmeral Runtime Enterprise. HPE Ezmeral Data Fabric on Bare Metal is also supported for non-production deployments.

HPE Ezmeral Data Fabric on Kubernetes

HPE Ezmeral Data Fabric on Kubernetes is an implementation of HPE Ezmeral Data Fabric in a Kubernetes cluster.

HPE Ezmeral Data Fabric on Kubernetes is available for use in non-production deployments of HPE Ezmeral Runtime Enterprise, but it is not supported for production environments.

Embedded Data Fabric

Embedded Data Fabric is a legacy implementation of HPE Ezmeral Data Fabric that is locally Embedded and runs on HPE Ezmeral Runtime Enterprise hosts.

Embedded Data Fabric is not supported on 5.5.0 and later releases of HPE Ezmeral Runtime Enterprise. Hewlett Packard Enterprise recommends using HPE Ezmeral Data Fabric on Bare Metal for production deployments. For non-production deployments, you can use either HPE Ezmeral Data Fabric on Bare Metal or HPE Ezmeral Data Fabric on Kubernetes.

In an HPE Ezmeral Runtime Enterprise deployment, only one HPE Ezmeral Data Fabric instance can be registered as Tenant/Persistent storage.

Table 2. HPE Ezmeral Data Fabric as Tenant/Persistent Storage
HPE Ezmeral Runtime Enterprise Release Version HPE Ezmeral Data Fabric on Bare Metal HPE Ezmeral Data Fabric on Kubernetes1 Embedded Data Fabric2
5.6.4 7.2 1.5.2 Not supported
5.6.2 7.2 1.5.2 Not supported
5.6.1 7.2 1.5.2 Not supported
5.6.0 7.0 and 6.2 1.5.2 Not supported
5.5.0-5.5.1 7.0 and 6.2 1.5.2 Not supported
5.4.1 6.2 1.5.1 Not supported for new deployments
5.4.0 6.2 1.5.0 Not supported for new deployments
5.3.5-5.3.6 Not supported 1.4.1 Discouraged 3
5.3.1 Not supported 1.4.1 Discouraged 3

1 Beginning with HPE Ezmeral Runtime Enterprise 5.5.0, HPE Ezmeral Data Fabric on Kubernetes is supported in non-production environments only.

2 Embedded Data Fabric aligns with HPE Ezmeral Data Fabric on bare metal Core 6.1.

3 "Discouraged" means that Hewlett Packard Enterprise strongly recommends that you upgrade to the latest release of HPE Ezmeral Runtime Enterprise (5.4.x, 5.5.0 or later) and migrate existing Embedded Data Fabric deployments toHPE Ezmeral Data Fabric on Bare Metal, or (for non-production deployments only) HPE Ezmeral Data Fabric on Kubernetes. For more information, contactHewlett Packard Enterprise Technical Support.

Table 3. External Storage Connections to HPE Ezmeral Data Fabric on Bare Metal
HPE Ezmeral Runtime Enterprise HPE Ezmeral Data Fabric on Bare Metal
5.6.4 7.2 and 6.2.0 (As tenant/persistent storage and as external storage)

6.1.0 (As external storage only)

5.6.2 7.2 and 6.2.0 (As tenant/persistent storage and as external storage)

6.1.0 (As external storage only)

5.6.1 7.2 and 6.2.0 (As tenant/persistent storage and as external storage)

6.1.0 (As external storage only)

5.6.0 7.0 and 6.2.0 (As tenant/persistent storage and as external storage)

6.1.0 (As external storage only)

5.5.0-5.5.1 7.0 and 6.2.0 (As tenant/persistent storage and as external storage)

6.1.0 (As external storage only)

5.4.0-5.4.1 6.2.0 (As tenant/persistent storage and as external storage)

6.1.0 (As external storage only)

5.3.1, 5.3.5, or 5.3.6

(with HPE Ezmeral Data Fabric on Kubernetes version 1.4.1)

6.1.0 or 6.2.0
Table 4. Container Versions for HPE Ezmeral Data Fabric on Kubernetes
HPE Ezmeral Runtime Enterprise Release Version HPE Ezmeral Data Fabric on Kubernetes Version Core HPE Ezmeral Data Fabric Components CSI OS Version (Base Containers) Alpine Version (Operators) Open LDAP
5.6.4 1.5.2 6.2.0.23 FUSE POSIX CSI v1.2.8 (Default)

NFS-loopback CSI v1.0.7

Rocky Linux release 8.4 Alpine Linux v3.13 1.5.0
5.6.2 1.5.2 6.2.0.23 FUSE POSIX CSI v1.2.8 (Default)

NFS-loopback CSI v1.0.7

Rocky Linux release 8.4 Alpine Linux v3.13 1.5.0
5.6.1 1.5.2 6.2.0.23 FUSE POSIX CSI v1.2.7 (Default)

NFS-loopback CSI v1.0.7

Rocky Linux release 8.4 Alpine Linux v3.13 1.5.0
5.6.0 1.5.2 6.2.0.23 FUSE POSIX CSI v1.2.7 (Default)

NFS-loopback CSI v1.0.7

Rocky Linux release 8.4 Alpine Linux v3.13 1.5.0
5.5.0-5.5.1 1.5.2 6.2.0.23 FUSE POSIX CSI v1.2.7 (Default)

NFS-loopback CSI v1.0.5

Rocky Linux release 8.4 Alpine Linux v3.13 1.5.0
5.4.1 1.5.1 6.2.0.18 FUSE POSIX CSI v1.2.5 (Default)

NFS-loopback CSI v1.0.5

Rocky Linux release 8.4 (Green Obsidian) 3.13.5 1.5.0
5.4.0 1.5.0 6.2.0.11 FUSE POSIX CSI v1.2.5 (Default)

NFS-loopback CSI v1.0.5

Rocky Linux release 8.4 (Green Obsidian) 3.13.5 1.5.0
5.3.5-5.3.6 1.4.1 6.206 EBF FUSE POSIX CSI v1.2.5 (Default)

NFS-loopback CSI v1.0.5

CentOS 8.3.2011 3.13 1.5
5.3.1 1.4.1 6.206 EBF FUSE POSIX CSI v1.2.1 (Default)

NFS-loopback CSI v1.0.1

CentOS 8.3.2011 3.13 1.5

See also:

Kubernetes Versions

The supported versions of Kubernetes vary by host OS and whether the Kubernetes cluster is imported into HPE Ezmeral Runtime Enterprise. See HPE Ezmeral Runtime Enterprise Components and Version Requirements for Imported Kubernetes Clusters.

In some cases, you can update Kubernetes to later versions than listed for yourHPE Ezmeral Runtime Enterprise release version without upgrading HPE Ezmeral Runtime Enterprise. See Kubernetes Bundles.

For additional Kubernetes requirements, see also:

Table 5. Kubernetes Versions by HPE Ezmeral Runtime Enterprise Version and Host OS
HPE Ezmeral Runtime Enterprise Release Version Kubernetes versions for RHEL/CentOS hosts Kubernetes versions for SLES hosts
5.6.4

1.24.8-hpe2, 1.25.12-hpe1 and 1.26.7-hpe1

1.24.8-hpe2, 1.25.12-hpe1 and 1.26.7-hpe1

5.6.2

1.22.15-hpe4, 1.23.16-hpe1 and 1.24.10-hpe1

5.6.1

1.22.15-hpe4, 1.23.16-hpe1 and 1.24.10-hpe1

1.22.15-hpe4, 1.23.16-hpe1 and 1.24.10-hpe1

5.6.0 1.22.15-hpe3, 1.23.14-hpe2 and 1.24.8-hpe2

1.22.15-hpe3, 1.23.14-hpe2 and 1.24.8-hpe2

5.5.1 1.22.15-hpe1, 1.23.13-hpe1

1.21.14-hpe2 (Supported during migration only3)

1.21.14, 1.22.11, 1.23.8 (Supported during migration only2)

1.22.15-hpe1, 1.23.13-hpe1

1.21.14-hpe2 (Supported during migration only3)

1.21.14, 1.22.11, 1.23.8 (Supported during migration only2)

5.5.0 1.22.12-hpe1, 1.23.9-hpe1

1.21.14-hpe1 (Supported during migration only1)

1.21.14, 1.22.11, 1.23.8 (Supported during migration only2)

1.22.12-hpe1, 1.23.9-hpe1

1.21.14-hpe1 (Supported during migration only1)

1.21.14, 1.22.11, 1.23.8 (Supported during migration only2)

5.4.1 1.19.15, 1.20.11, 1.21.10 Not Supported
5.4.0 1.19.15, 1.20.11, 1.21.3 Not Supported
5.3.6 1.18.6, 1.19.15, 1.20.11 1.18.6 (CaaS 4.5)
5.3.5 1.18.6, 1.19.5, 1.20.2 1.18.6 (CaaS 4.5)
5.3.1 1.18.6, 1.19.5, 1.20.2 1.18.6 (CaaS 4.5)

1 Supported during migration of existing Kubernetes clusters to 1.23.9-hpe1 (preferred) or to 1.22.12-hpe1. Not supported for new Kubernetes clusters or for ongoing operations in a production deployment.

2 Supported for existing Kubernetes clusters until those legacy clusters are migrated to a Hewlett Packard Enterprise distribution of Kubernetes. You cannot upgrade a legacy Kubernetes cluster without also migrating the cluster to a Hewlett Packard Enterprise distribution of Kubernetes. Not supported for new Kubernetes clusters or for ongoing operations in a production deployment.

3 Supported during migration of existing Kubernetes clusters to 1.23.13-hpe1 (preferred) or to 1.22.15-hpe1. Not supported for new Kubernetes clusters or for ongoing operations in a production deployment.

Imported Kubernetes Clusters

HPE Ezmeral Runtime Enterprise 5.6.x or higher does not support Imported Kubernetes clusters.

HPE Ezmeral Runtime Enterprise Release Version Imported Kubernetes clusters
5.6.4 Not Supported
5.6.2 Not Supported
5.5.0-5.5.1 Not Supported
5.4.0-5.4.1 Not Supported
5.3.5-5.3.6 Supported. See Imported Cluster Types and Versions
5.3.1 Supported. See Imported Cluster Types and Versions
NOTICE End of Life (EOL) for Elastic Private Instant Clusters (EPIC)

HPE Ezmeral Runtime Enterprise 5.4.1 is the last release that includes support for EPIC.  Beginning with the next general availability release, deployments that use EPIC to manage virtual nodes/containers are not supported. No future enhancements to EPIC are planned; however, support (such as bug fixes) will continue to be provided until the EPIC functionality reaches End of Life (EOL).

Existing deployments that use EPIC can be transitioned to the newer Kubernetes-based solution on the latest HPE Ezmeral Runtime Enterprise release. Existing deployments that continue to use EPIC will be supported until EPIC reaches End of Life (EOL) on December 30, 2024.

Version Requirements for Imported Kubernetes Clusters

Imported Kubernetes clusters are not supported on HPE Ezmeral Runtime Enterprise 5.4.x, 5.5.x or later releases.

HPE Ezmeral Runtime Enterprise 5.2.x and 5.3.x releases support the following Kubernetes versions for clusters that are imported into the platform.

NOTE

Import is supported for Kubernetes versions shown in the following table, even if the version is not one of the versions supported for clusters created by HPE Ezmeral Runtime Enterprise.

Imported clusters do not support add-ons.

Table 6. Imported Cluster Types and Versions
Kubernetes Service Supported Versions for Imported Clusters
Amazon Elastic Kubernetes Service (EKS) 1.18, 1.19
Google Kubernetes Engine (GKE) 1.18.16-gke-302, 1.18.16-gke-502
Azure Kubernetes Service (AKS) 1.18.14, 1.19.7, 1.20.2
VMware Tanzu Kubernetes Grid (PKS) 1.7

Add-On Versions

The following table lists the versions of system and application add-ons by HPE Ezmeral Runtime Enterprise release. KubeDirector is a prerequisite for the analytics and HPE Ezmeral ML Ops add-ons.

In some cases, you can update add-ons to later versions without upgrading HPE Ezmeral Runtime Enterprise to a later version. See Kubernetes Bundles.

For version information about the container runtimes, HPECP agent, and kubectl, see HPE Ezmeral Runtime Enterprise Components.

Table 7. Analytics and HPE Ezmeral ML Ops Add-On Versions
HPE Ezmeral Runtime Enterprise Release Version KubeDirector Apache Spark Kubeflow Airflow MLflow
5.6.4 0.11.0-9726ef0 1.3.8.0 ( Contains Apache Spark 2.4.7 and Apache Spark 3.3.1) Not prepackaged as add-on. Contact HPE Technical Support team for more details. Not prepackaged as add-on. Contact HPE Technical Support team for more details. N/A (Replaced by integrated model management framework.)
5.6.2 0.11.0-9726ef0 1.3.8.0 ( Contains Apache Spark 2.4.7 and Apache Spark 3.3.1) 1.7-0fc57da (Contains Kubeflow 1.6-0fc57da) 2.3-2b38953 (Contains Airflow 2.4.3) N/A (Replaced by integrated model management framework.)
5.6.1 0.11.0-9726ef0 1.3.8.0 ( Contains Apache Spark 2.4.7 and Apache Spark 3.3.1) 1.7-0fc57da (Contains Kubeflow 1.6-0fc57da) 2.3-2b38953 (Contains Airflow 2.4.3) N/A (Replaced by integrated model management framework.)
5.6.0 0.11.0-9726ef0 1.3.8.0 ( Contains Apache Spark 2.4.7 and Apache Spark 3.3.1) 1.7-0fc57da (Contains Kubeflow 1.6-0fc57da) 2.3-2b38953 (Contains Airflow 2.4.3) N/A (Replaced by integrated model management framework.)
5.5.1 0.11.0-9726ef0 1.3.8.0-14ea66c-5455643 ( Contains Apache Spark 2.4.7 and Apache Spark 3.2.0) 1.6-d475bce 2.3-2b38953 (Contains Airflow 2.4.3) N/A (Replaced by integrated model management framework.)
5.5.0 0.11.0-9726ef0 1.3.7.1-1a83a98-5455643 ( Contains Apache Spark 2.4.7 and Apache Spark 3.2.0) 1.6-fd89c89 2.2-ce70c0b (Contains Airflow 2.3.4) N/A (Replaced by integrated model management framework.)
5.4.1 0.9.0 Apache Spark 2.4.7 and Apache Spark 3.1.2 1.3* Airflow 2.2.5 KDApp MLflow 1.5, includes MLFlow Tracking 1.12.0 (Technical Preview)
5.4.0 0.8.1 Apache Spark 2.4.7 and Apache Spark 3.1.2 1.3* Airflow 2.2.0 KDApp MLflow 1.5, includes MLFlow Tracking 1.12.0 (Technical Preview)
5.3.5-5.3.6 0.6.2 Apache Spark 2.4.7 and Apache Spark 3.1.1 (Preview) 1.2 (With Istio 1.3.1) Airflow 2.0.1 KDApp MLflow 1.5, includes MLFlow Tracking 1.12.0 (Technical Preview)
5.3.1 0.6.1 Apache Spark 2.4.7 and Apache Spark 3.1.1 (Preview) 1.2 (With Istio 1.3.1) Airflow 2.0 KDApp MLflow 1.5, includes MLFlow Tracking 1.12.0 (Technical Preview)

* Istio is a prerequisite for Kubeflow 1.3 and later. However, Istio 1.9.8, which is the version of Istio that is shipped with HPE Ezmeral Runtime Enterprise 5.4.0 or 5.4.1, is not supported on Kubernetes 1.21 and later. HPE Ezmeral Runtime Enterprise prevents existing clusters that have Istio 1.9.8 from being upgraded to Kubernetes 1.21.x.

Table 8. Platform Add-On Versions
HPE Ezmeral Runtime Enterprise Release Version Istio Service Mesh Argo CD Falco Open Policy Agent Gatekeeper Data Fabric Tenant Operator NVIDIA plug-in
5.6.4 1.14.5 2.5.2-04f50a2 0.33.0-04f50a2 3.10.0-04f50a2 picasso-1.5.2-GA-ERE56-drop1-75-0 0.12.3-04f50a2
5.6.2 1.14.5 2.5.2-04f50a2 0.33.0-04f50a2 3.10.0-04f50a2 picasso-1.5.2-GA-ERE56-drop1-75-0 0.12.3-04f50a2
5.6.1 1.14.5 2.5.2-04f50a2 0.33.0-04f50a2 3.10.0-04f50a2 picasso-1.5.2-GA-ERE56-drop1-75-0 0.12.3-04f50a2
5.6.0 1.14.5 2.5.2-ba31668 0.33.0-b9eff56 3.10.0-d006b58 picasso-1.5.2-GA-ERE56-drop1-75-0 0.12.3-d006b58
5.5.1 1.13.5-e3f62ee 2.4.17-3c54efb 0.32.2-a3473ed 3.10.0-58c0a78 picasso-1.5.2-drop1-74-0 0.12.3-4ae1978
5.5.0 1.13.5-547eb22 2.2.5-ad3d17b 0.32.2-a3473ed 3.9.0-ad3d17b picasso-1.5.2-drop1-74-0 0.12.3-4ae1978
5.4.1 1.9.8* ArgoCD 2.2.5 Falco 2.23.1 3.7.0-7 picasso-1.5.1-P151RC2-71-0 0.9.0
5.4.0 1.9.8* ArgoCD 2.2.5 Falco 2.23.1 3.7.0-4 picasso-1.5.0-P150RC10-69-0 0.9.0
5.3.5-5.3.6 1.9.0 ArgoCD 1.8.4 Falco 2.21.0 3.3.0-2 picasso-1.4.1-drop7-43-2 0.9.0
5.3.1 1.7.1 ArgoCD 1.8.4 Falco 2.21.0 3.3.0-2 picasso-1.4.1-drop7-43-1 1.0.0-beta-6

* Istio is a prerequisite for Kubeflow 1.3 and later. However, Istio 1.9.8, which is the version of Istio that is shipped with HPE Ezmeral Runtime Enterprise 5.4.0 or 5.4.1, is not supported on Kubernetes 1.21 and later. HPE Ezmeral Runtime Enterprise prevents existing clusters that have Istio 1.9.8 from being upgraded to Kubernetes 1.21.x.

Table 9. Platform Add-On Versions, Monitoring
HPE Ezmeral Runtime Enterprise Release Version Monitoring NVIDIA GPU Metrics ERE Service Accounts Kube State Metrics Kubernetes Dashboard Metrics Server
5.6.4 6.6.7-04f50a2 6.6.3-04f50a2 0.2-04f50a2 6.6.3-a4fbfa3 v2.7.0-04f50a2 v0.6.2-04f50a2
5.6.2 6.6.7-04f50a2 6.6.3-04f50a2 0.2-04f50a2 6.6.3-a4fbfa3 v2.7.0-04f50a2 v0.6.2-04f50a2
5.6.1 6.6.7-04f50a2 6.6.3-04f50a2 0.2-04f50a2 6.6.3-a4fbfa3 v2.7.0-04f50a2 v0.6.2-04f50a2
5.6.0 6.6.7-b9eff56 6.6.3-a4fbfa3 0.2-da188d2 6.6.3-a4fbfa3 v2.7.0-0349604 v0.6.2-15bd0b2
5.5.1 6.6.7-6155d23 6.5.5-6155d23 0.2-6155d23 2.3.0-db64c34 v2.7.0-a650c50 v0.6.1-6155d23
5.5.0 6.6.7-6155d23 6.5.5-6155d23 0.2-6155d23 2.3.0-db64c34 v2.7.0-a650c50 v0.6.1-6155d23
5.4.1 6.6.5-8.0 6.5.5 0.2-4 1.9.6-2 2.0.0-rc2-4 0.3.6-4
5.4.0 6.6.5-8.0 6.5.5 0.2-4 1.9.6-2 2.0.0-rc2-3 0.3.6-4
5.3.5-5.3.6 6.6.5-7.0 6.5.5 0.2-2 1.9.6-2 2.0.0-rc2-2 0.3.6-4
5.3.1 6.6.5-7.0 6.5.5 0.2-2 1.9.6-2 2.0.0-rc2-2 0.3.6-4

Kubernetes Bundles

The following table lists the versions and content of Kubernetes bundles and their compatible versions of HPE Ezmeral Runtime Enterprise. For more information about Kubernetes bundles, see Kubernetes Bundles.

Table 10. Kubernetes Bundles
Kubernetes Bundle Version Compatible HPE Ezmeral Runtime Enterprise Versions Kubernetes Versions Add-On Versions EOL Date
2.1.21 5.6.4 1.24.8-hpe2, 1.25.12-hpe1 and 1.26.7-hpe1
Airflow (2.3-04f50a2)
ArgoCD (2.5.2-04f50a2)
ERE Service Accounts (0.2-04f50a2)
Falco (0.33.0-04f50a2)
HPECP Agent (1.3.1-7e1d6f6-04f50a2)
Istio (1.14.5-04f50a2)
KubeDirector (0.11.0-04f50a2)
Kubeflow (1.6-5.6.1-67dcdba)
Kubernetes Dashboard (v2.7.0-04f50a2)
Metrics Server (v0.6.2-04f50a2)
Monitoring (6.6.7-04f50a2)
NVIDIA GPU Metrics (6.6.3-04f50a2)
NVIDIA plugin (0.12.3-04f50a2)
Open Policy Agent Gatekeeper (3.10.0-04f50a2)
Spark Operator (1.3.8.1-82f8759-04f50a2)
Tenant Operator (picasso-1.5.2-GA-ERE56-drop1-75-0)
hpecp-bootstrap-prometheus (41.7.4-04f50a2)
25 JAN 2024
2.1.22 5.6.2 1.22.15-hpe4 1.23.16-hpe1 1.24.10-hpe1
Airflow (2.3-04f50a2)
ArgoCD (2.5.2-04f50a2)
ERE Service Accounts (0.2-04f50a2)
Falco (0.33.0-04f50a2)
HPECP Agent (1.3.1-7e1d6f6-04f50a2)
Istio (1.14.5-04f50a2)
KubeDirector (0.11.0-04f50a2)
Kubeflow (1.6-5.6.1-67dcdba)
Kubernetes Dashboard (v2.7.0-04f50a2)
Metrics Server (v0.6.2-04f50a2)
Monitoring (6.6.7-04f50a2)
NVIDIA GPU Metrics (6.6.3-04f50a2)
NVIDIA plugin (0.12.3-04f50a2)
Open Policy Agent Gatekeeper (3.10.0-04f50a2)
Spark Operator (1.3.8.1-82f8759-04f50a2)
Tenant Operator (picasso-1.5.2-GA-ERE56-drop1-75-0)
hpecp-bootstrap-prometheus (41.7.4-04f50a2)
2.1.13 5.6.1 1.22.15-hpe4 1.23.16-hpe1 1.24.10-hpe1
Airflow (2.3-04f50a2)
ArgoCD (2.5.2-04f50a2)
ERE Service Accounts (0.2-04f50a2)
Falco (0.33.0-04f50a2)
HPECP Agent (1.3.1-7e1d6f6-04f50a2)
Istio (1.14.5-04f50a2)
KubeDirector (0.11.0-04f50a2)
Kubeflow (1.6-5.6.1-67dcdba)
Kubernetes Dashboard (v2.7.0-04f50a2)
Metrics Server (v0.6.2-04f50a2)
Monitoring (6.6.7-04f50a2)
NVIDIA GPU Metrics (6.6.3-04f50a2)
NVIDIA plugin (0.12.3-04f50a2)
Open Policy Agent Gatekeeper (3.10.0-04f50a2)
Spark Operator (1.3.8.1-82f8759-04f50a2)
Tenant Operator (picasso-1.5.2-GA-ERE56-drop1-75-0)
hpecp-bootstrap-prometheus (41.7.4-04f50a2)
2.0.04 5.6.0
1.22.15-hpe3
1.23.14-hpe2 
1.24.8-hpe2
Airflow (2.3-67a049e)
ArgoCD (2.5.2-ba31668)
ERE Service Accounts (0.2-da188d2)
Falco (0.33.0-b9eff56)
HPECP Agent (1.3.0-8bf3031-2e67bb4)
Istio (1.14.5-d006b58)
KubeDirector (0.11.0-7c59acf)
Kubeflow (1.6-5.6.0-0c86715)
Kubernetes Dashboard (v2.7.0-0349604)
Metrics Server (v0.6.2-15bd0b2)
Monitoring (6.6.7-b9eff56)
NVIDIA GPU Metrics (6.6.3-a4fbfa3)
NVIDIA plugin (0.12.3-d006b58)
Open Policy Agent Gatekeeper (3.10.0-d006b58)
Spark Operator (1.3.8.0-e69e44a-d88da3c)
Tenant Operator (picasso-1.5.2-GA-ERE56-drop1-75-0)
hpecp-bootstrap-prometheus (41.7.4-d49d66c)
2.0.05 5.5.1
1.22.15-hpe3
1.23.14-hpe2 
1.24.8-hpe2
Airflow (2.3-67a049e)
ArgoCD (2.5.2-ba31668)
ERE Service Accounts (0.2-da188d2)
Falco (0.33.0-b9eff56)
HPECP Agent (1.3.0-8bf3031-2e67bb4)
Istio (1.14.5-d006b58)
KubeDirector (0.11.0-7c59acf)
Kubeflow (1.6-5.6.0-0c86715)
Kubernetes Dashboard (v2.7.0-0349604)
Metrics Server (v0.6.2-15bd0b2)
Monitoring (6.6.7-b9eff56)
NVIDIA GPU Metrics (6.6.3-a4fbfa3)
NVIDIA plugin (0.12.3-d006b58)
Open Policy Agent Gatekeeper (3.10.0-d006b58)
Spark Operator (1.3.8.0-e69e44a-d88da3c)
Tenant Operator (picasso-1.5.2-GA-ERE56-drop1-75-0)
hpecp-bootstrap-prometheus (41.7.4-d49d66c)
1.0.46 5.5.1, 5.5.0
1.21.14-hpe2 
1.22.15-hpe1
1.23.13-hpe1
Airflow (2.3-2b38953)
ArgoCD (2.4.17-3c54efb)
ERE Service Accounts (0.2-6155d23)
Falco (0.32.2-a3473ed)
HPECP Agent (1.2.7-234eba4-6155d23)
Istio (1.13.5-e3f62ee)
Kube State Metrics (2.3.0-db64c34)
KubeDirector (0.11.0-9726ef0)
Kubeflow (1.6-d475bce)
Kubernetes Dashboard (v2.7.0-a650c50)
Metrics Server (v0.6.1-6155d23)
Monitoring (6.6.7-6155d23)
NVIDIA GPU Metrics (6.5.5-6155d23)
NVIDIA plugin (0.12.3-4ae1978)
Open Policy Agent Gatekeeper (3.10.0-58c0a78)
Spark Operator (1.3.8.0-14ea66c-5455643)
Tenant Operator (picasso-1.5.2-drop1-74-0)
22 OCT 2023
1.0.37 5.5.0
1.21.14-hpe1 
1.22.12-hpe1
1.23.9-hpe1
airflow 2.2-ce70c0b
argocd 2.2.5-ad3d17b
falco 0.32.2-a3473ed
hpecp-agent 1.2.5-5df266a-6155d23
hpecp-monitoring 6.6.7-6155d23
hpecp-nvidiagpubeat 6.5.5-6155d23
hpecp-serviceaccounts 0.2-6155d23
istio 1.13.5-547eb22
kube-state-metrics 2.3.0-db64c34
kubedirector 0.11.0-9726ef0
kubeflow 1.6-fd89c89
kubernetes-dashboard v2.7.0-a650c50
metrics-server v0.6.1-6155d23
nvidia-plugin 0.12.3-4ae1978
opa-gatekeeper 3.9.0-ad3d17b
picasso picasso-1.5.2-drop1-74-0
spark-operator 1.3.7.1-1a83a98-5455643
22 OCT 2023
1 Included in the HPE Ezmeral Runtime Enterprise 5.6.4 package.
2 Included in the HPE Ezmeral Runtime Enterprise 5.6.2 package.
3 Included in the HPE Ezmeral Runtime Enterprise 5.6.1 package.
4 Included in the HPE Ezmeral Runtime Enterprise 5.6.0 package.
5 Included in the HPE Ezmeral Runtime Enterprise 5.6.0 package.
6 Included in the HPE Ezmeral Runtime Enterprise 5.5.1 package.
7 Included in the HPE Ezmeral Runtime Enterprise 5.5.0 package.

Kubernetes Applications

See the following:

Kubeflow Components (5.6.x and higher)

Kubeflow Operator version is 1.6.

Beginning with HPE Ezmeral Runtime Enterprise 5.5.1, Kubeflow notebooks are available. However, Hewlett Packard Enterprise recommends that you use full-featured KubeDirector notebooks instead.

The following table lists the components that Kubeflow deploys.

Table 11. Kubeflow Components (5.6.x and higher)
Component Version in HPE Ezmeral Runtime Enterprise 5.6.x
Cert Manager 1.5.0
Dex 2.31.2
Katib 0.14.0
Kserve 0.8.0
Knative 1.2.5
Kubeflow Dashboard ecp-5.6.0-release
ML Metadata 2.0.0-alpha.3
ML Pipelines (KFP) 2.0.0-alpha.3
Prism ecp-5.6.0-release
Profile Controller (KFAM) 1.6.0
Seldon 1.12.0
Tensorboard ecp-5.6.0-release
Training Operator 1-e1434f6
Volumes Web App 1.6.0
Workflow Controller 3.2.3

Kubeflow Components (5.5.x)

Kubeflow Operator version is 1.6.

Beginning with HPE Ezmeral Runtime Enterprise 5.5.1, Kubeflow notebooks are available. However, Hewlett Packard Enterprise recommends that you use full-featured KubeDirector notebooks instead.

The following table lists the components that Kubeflow deploys.

Table 12. Kubeflow Components (5.5.x)
Component Version in HPE Ezmeral Runtime Enterprise 5.5.x
Cert Manager 1.5.0
Dex 2.31.2
Katib 0.14.0
Kserve 0.8.0
Knative 1.2.4
Kubeflow Dashboard ecp-5.5.0-release
ML Metadata 2.0.0-alpha.3
ML Pipelines (KFP) 2.0.0-alpha.3
Prism ecp-5.5.0-release
Profile Controller (KFAM) 1.6.0
Seldon 1.12.0
Tensorboard v1.6.0
Training Operator 1-e1434f6
Volumes Web App 1.6.0
Workflow Controller 3.2.3

Kubeflow Components (5.4.0-5.4.1)

The Kubeflow Operator version is: 1.3

The following table lists the components that Kubeflow deploys.

Table 13. Kubeflow Components (5.4.0-5.4.1)
Component Version in HPE Ezmeral Runtime Enterprise 5.4.0 and 5.4.1
Dex 2.24.0
Katib 0.11.0
Kfserving 0.6.0
Knative 0.22.1
Kubeflow Dashboard 1.3.0-rc.1
ML Metadata 1.5.0
MPI Operator 0.2.3
MXNet Operator 1.1.0
Notebook Controller 1.3.0-rc.1
Kubeflow Pipelines (KFP) 1.5.0
Profile Controller 1.3.0-rc.1
Pytorch 0.7.0
Seldon 1.9.0
Tensorboard Controller 1.3.0-rc.1
TFJob Operator 1.1.0
Volumes Web App 1.3.0-rc.1
XGBoost Operator 0.2.0